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Clovify
Where do | put custom DOCX templates?

The Help menu

From the help menu select Reveal Custom Template Folder. This will show the folder where
custom templates go.
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The Templates folder will have a number of folders. You will put custom DOCX templates that
you create in the DOCX folder.
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How is a DOCX template structured?

Here is the structure of a DOCX template folder.

1. The root folder is the name that will appear in Clarify.

2. The DOCKX file that will be used for exporting your Clarify documents goes in the ./Content/
article folder. The name of the DOCX file is irrelevant. All that matters is that it have a .docx
extension.

3. ADOCX template can also have a ./Content/manual folder. This is not used in Clarify but
can be present since Clarify DOCX templates use the same format as ScreenSteps DOCX
templates.
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Creating a Template
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Adding styles to the template

When Clarify generates a DOCX file it assigns certain styles to the content. You will need to
add these styles to your DOCX template in order for the content to look correct.

Note that some of the styles listed are only applicable to ScreenSteps and not Clarify. These
styles are listed so that you can add them in case you ever want to use the template with
ScreenSteps.

You will need to add the following styles to your document.

+ Chapter Heading: Styles chapter titles. [ScreenSteps only]

+ Article Description: Styles article descriptions.

+ Article Heading: Styles article titles.

+ Step Heading: Styles step titles.

+ Substep Heading: Styles sub-step titles.

+ Step Instructions: Styles step text.

+ ScreenSteps Code: Styles code blocks in step text.

+ ScreenSteps Code Run: Styles instances of code within paragraph text.

+ ScreenSteps List Number, ScreenSteps List Number 2, ScreenSteps List Number 3, ...:
Styles numbered lists. Create as many entries as levels of nesting your documents may
have. The templates included with Clarify go up to ScreenSteps List Number 5.

+ ScreenSteps List Bullet, ScreenSteps List Bullet 2, ScreenSteps List Bullet 3, ...: Styles
bullet lists. Create as many entries as levels of nesting your documents may have. The
templates included with Clarify go up to ScreenSteps List Bullet 5.

+ Step Image: Styles step images.

Opening the Styles editor (Word 2013 on Windows)

From the Home tab click on the arrow next to Styles.
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Click on Manage Styles

REEERCRLTCE KAALIRIZT DCLAICAS

Styles vx

Clear All

4

Mormal

Mo Spacing
Heading 1
Heading 2

Title

Subtitle

Subtle Emphasis
Emphasis

Intense Emphasis

powowow s 222 a2

Strong

Quote -

Show Preview
Disable Link fles

| |2 A Options..,

Manage Styles

Manage Styles

From the Manage Styles window you can add the styles you need to by clicking on New Style.
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Manage Styles ?

Edit Recommend | Restrict | Set Defaults
Sort order: | As Recommended W |:| Show recommended styles only

Select a style to edit

& Default Paragraph Font [Hide Until Used)
1 Mo Spacing
T3 Heading 1
T3 Heading 2 (Hide Until Used)
T3 Heading 3 (Hide Until Used)
T3 Heading 4 (Hide Until Used)
T4 Heading 5 (Hide Until Used)
T4 Heading & [Hide Until Used)
T3 Heading 7 (Hide Until Used) hd

Preview of Mormal:

+Body Modify...

11 pt

Font: (Default) «EBody (Calibri), Left
Line spacing: Multiple 1.0 i, Space

After: 8 pt, Widow/Crpha ol, Style: Show in the Styles gallery
Hew Style...

(®) Only in this document () Mew documents based on this template

Import/Export...

Cancel

Chapter Heading, Article Heading, Step Heading, and

Substep Heading

For the heading styles you can base them off of existing heading styles that come with Word.

If you are creating a manual template then base Chapter Heading on Heading 1, Article

Heading on Heading 2, etc.

If you are creating an article template then you can base Article Heading on Heading 1, Step

Heading on Heading 2, etc.
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Create New Style from Formatting ?
Properties \

HName: .Chapter Heading

Style type: \ Paragraph L%

Style based on: v

Style for following paragraph: ' Chapter Heading W
Formatting

Calibri Light (Heacw | |16 |w|| B T U | NG

=]

i
i
i
i

Sample Text Sample Text Sample Text Sample Text Sample Text Sample
Text Sample Text Sample Text Sample Text Sample Text Sample Text
Sample Text Sample Text Sample Text Sample Text Sample Text Sample
Text Sample Text Sample Text Sample Text Sample Text

Style: Show in the Styles gallery
EBased on: Heading 1

|:| Add to the Styles gallery |:| Automatically update

(® Only in this document () Mew documents based on this template

Format = Cancel

Article Description and Step Instructions

Article Description and Step Instructions can be based off of the Normal style. If you want to
make any changes to how the text appears then use the Format menu to change text and
paragraph properties.
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Create New Style from Formatting ?

Properties

MName: Article Description

Style type: \ Paragraph W

Style based on: T Normal W

Style for following paragraph: 7 Article Description W
Formatting

Calibri (Body) w M|w | B I U Automatic W

= ==|= = = |12 12| = =

‘ ‘Sample Text Sample Text Sample Text Sample Text Sample Text Sample Text Sampls Text Sampls Text

F mple Text Sample Text Sample Text Sample Text Sample Text Sample Text
Font... mple Text Sample Text Sample Text
Paragraph...

Tabs...

Border...

Language... allery
Frame...
Mumbering...

Shortcut key... |:| Automatically update
Text Effects... ) Mew documents based on this template

ScreenSteps Code

The ScreenSteps Code style is used to format code blocks and is based on the Normal style.
Here are some baseline settings you can use for code blocks:

+ Font: Courier New, color set to 51,51,51.

« Border: Box with a solid line set to 1 pt thick with color set to 208,208,208. The border
padding is set to 8 pt on top, left, bottom, and right. The shading is set to 245,245,245. This
provides the background color.
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Create New Style from Formatting ?

Properties

Mame: ScreenSteps Code

Style type: Paragraph &
Style based on: 1 Mormal W
Style for following paragraph: 1 Screensteps Code W
Farmatting

Calibri [Body} w11 v| B I Q| Automatic W
EIEEE|E=:|*§*§|'—_
= = = = = b= 4= €= =

Code Example

Create New Style from Formatting ?
Properties
MName: Screensteps Code
Style type: Paragraph W
Style based on: T Normal W
Style for following paragraph: 1 ScreenSteps Code W
Formatting

Courier New vwim|w| B I U I

o
Il
il
Il
Il
IIf
1l
il
Wi
fi
fi

I

Sample Text Jample Text Jample Text Sample Text Sample Text Jampls Text
Sample Text Jample Text Jample Text Sample Text Sample Text Jample Text
Sample Text Jample Text Jample Text Jample Text Sample Text Jampls Text
Sample Text Jample Text Jample Text

Taop: (Single solizj ling, Custom Color[P:GB[Z{!E-,Z{!E,P_OE]], 1 pt Line width, From text: 2 pt
Border spacing: )
Bottom: (Single solid line, Custom Color(RGE(208,208,208)), 1 pt Line width, From text: & pt ¥
|:| Add to the Styles gallery |:| Automatically update
'Z§Z' Cinly in this document 'Z:Z' Mew documents based on this template

Format = Cancel

ScreenSteps Code Run

The ScreenSteps Code Run style is used to format instances of code within a paragraph and is
a Character type based on the Default Paragraph Font style.

Here are some baseline settings you can use for code blocks:
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+ Font: Courier New, color set to 187,0,0.
+ Border: Go to the Shading tab and set the Fill to 224,224,224,

Create New Style from Formatiing ?

Properties

Mame: ScreenSteps Code Run
Style type: \ Character W
Style based on: d Default Paragraph Font W

Style for following paragraph

Formatting
Courier W w“w| B I U Automatic w | | Latin W
Step Image

The Step Image style can be based off of Normal. Use this style to add padding around the
image. For example, you might set the Space Before and Space After in the paragraph settings
to 18pt.

ScreenSteps List Bullet, ScreenSteps List Bullet 2,
ScreenSteps List Bullet 3, ScreenSteps List Bullet 4,
ScreenSteps List Bullet 5, ...

The ScreenSteps List Bullet styles can be based on the List Bullet styles included with Word.
Word defines all the way up to List Bullet 5.
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Create New Style from Formatting ?

Properties

MName: Screensteps List Bullet

Style type: v

Style based on: 0 List Bullet W

Style for following paragraph: 1 ScreenSteps List Bullet W
Formatting

Calibri (Body) w M|w | B I U Automatic W

B = = == = = |12 2| & =

Sample Text 33ample Text 3ample Text Sample Text Sample Text Sample Text Sample Text Sample Text
sample Text sample Text sample Text sample Text sample Text sample Text Sample Text Sample Text
Sample Text Sample Text Sample Text Sample Text Sample Text

Style: Show in the Styles gallery
Based on: List Bullet

|:| Add to the Styles gallery |:| Automatically update
'Z§Z' Qnly in this document 'Z:Z' Mew documents based on this template

Format = Cancel

ScreenSteps List Number, ScreenSteps List Number 1,
ScreenSteps List Number 2, ScreenSteps List Number 3,
ScreenSteps List Number 4, ScreenSteps List Number 5, ...

The ScreenSteps List Number styles need to be created by hand and based on Normal. DO
NOT base them on List Number. You will need to specify the tab and numbering settings.

Create New Style from Formatting ?

Properties \

Mame: Screensteps List Mumber

Style type: \ Paragraph W
Style based on: 1 Mormal W
Style for following paragraph: ' screenSteps List Number W
Formatting

Calibri [Body) wi 11w (| B I U Automatic W

= = = = — = = = 4= | = 5=

B = = = = = = = t=| = 7=
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Example Settings

Here are some example settings for list numbers.

Format > Tabs

For the Format > Tab settings you can start at 0.25" for level 1 and then move up in 0.25".

Tabs ?

Tab stop position:
0.25

Tab stops to be cleared:

Set Clear Clear All

Format > Paragraph

In the Paragraph settings set the Left indentation to 0.25". Set Special to Hanging by 0.25".
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Paragraph ?

Indents and Spacing | Line and Page Breaks |

General

Alignment: Left

[<]

Dutline level: | Body Text u Collapsed by default

k I

Indentation

Left: 0.25 Iil Special: e By:
Right: o =) Hanging :| 0.25° Ii"
[ ] Mirror indents

Spacing

Before: Opt El Line spacing: At

After: spt 5 Multiple v| [108 5]

|:| Don't add space between paragraphs of the same style

Format > Numbering and Bullets

Select a numbered list format for your lists.

Numbering and Bullets  ?

Mumbering | Bullets
Numbering Library &
1. 1)
None 2 2)
3. 3)
| A a)
I B b)
i c c)
a I
b. ii.
i v
Define Mew Mumber Format... |
. ok | | cancel
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Adding placeholders to an article template

Content placeholder

For an article template add the text [[SCREENSTEPS_ARTICLE]] to the document. This text
should have no styling applied to it.

El H ©- = Document] - Word
FILE HOME INSERT DESIGN PAGE LAYOUT REFEREMCES MAILINGS REVIEW

[[SCREENSTEPS_ARTICLE]] |

Header variables

You can place the [[ARTICLE_TITLE]] variable in the Header section of the template. The name
of the Clarify document will be inserted in place of the variable.

Footer variables

In the footer you can use the [[ARTICLE_TITLE]] and [[FOOTER_TEXT]]. The [[FOOTER_TEXT]]

variable is the footer text that you enter when configuring a sharing account in the Share
preference pane.
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Troubleshooting

If your variables are not being replaced when you export then it may be that Word has split the
variable text up into multiple blocks of text inside of the template file. Try retyping the variable
name again and then saving the document.
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